Ошибки/проблемы/неисправности системы

Новые релизы, обновления и т.п.

Модератор: immortal

kas58
Сообщения: 25
Зарегистрирован: Пн дек 12, 2016 7:51 am
Благодарил (а): 11 раз
Поблагодарили: 1 раз

Re: Ошибки/проблемы/неисправности системы

Сообщение kas58 » Вт окт 03, 2017 12:51 pm

nick7zmail писал(а):Хах)) Забавно. Попробуйте поменять, как вы раньше меняли, и не перезагружаясь выполнить это viewtopic.php?p=51790#p51790. Всё таки должно помочь.
Нет такого каталога /tmp/mysql/.
Вложения
ErrorBD1.PNG
ErrorBD1.PNG (12.32 КБ) 4913 просмотров
Urbas81
Сообщения: 289
Зарегистрирован: Вс сен 16, 2012 9:39 am
Благодарил (а): 0
Поблагодарили: 1 раз

Re: Ошибки/проблемы/неисправности системы

Сообщение Urbas81 » Пн окт 09, 2017 1:26 pm

Добрый день. Подскажите как решить проблему, у меня стояла система довольно старой версии 2013-2014 годов, сейчас посмотрел что добавилось много модулей, решил обновится, с трудом это удалось через обновление, но в меню появилось дублирование пунктов, иногда останавливаются цикли, хотя поставил их автоматический перезапуск, иногда не редактируются старые настройки, к примеру в 1wire изменяю свойства, нажимаю сохранить, но изменения не сохраняются, приходится через phpmyadmin править, так же часто портятся базы при старте, как с этим бороться. Возможно лучше поставить новую версию, а затем добавить нужные базы, но как это сделать правильно, чтобы не добавлять все сценарии и другие настройки вручную.
Аватара пользователя
xor
Сообщения: 1741
Зарегистрирован: Сб ноя 22, 2014 8:45 pm
Благодарил (а): 214 раз
Поблагодарили: 522 раза

Re: Ошибки/проблемы/неисправности системы

Сообщение xor » Вт окт 10, 2017 1:39 am

Посмотрите вкладку Structure в x-ray'е, я время от времени сохраняю эту страницу локально. Там практически всё показывается в человеческом виде (кроме галочек/крыжиков интерфейса).
Несколько раз выручало конкретно после неудачных опытов с разрушением базы когда не помогало восстановление из бэкапа.
Аватара пользователя
nick7zmail
Сообщения: 7530
Зарегистрирован: Пн окт 28, 2013 8:14 am
Откуда: Екатеринбург
Благодарил (а): 121 раз
Поблагодарили: 1991 раз

Re: Ошибки/проблемы/неисправности системы

Сообщение nick7zmail » Вт окт 10, 2017 6:11 am

kas58 писал(а): Нет такого каталога /tmp/mysql/.
Значит у вас какая-то не стандартная установка. Ищите, куда у вас база копируется.
Raspberry Pi3+Broadlink+esp8266 (blynk)+AMS
Если вам помогло какое-либо сообщение - не забывайте пользоваться кнопкой "СПАСИБО".
:arrow: Услуги в профиле коннект
>>>>>Мой новый канал на ютутбе, подписывайтесь!<<<<<
Urbas81
Сообщения: 289
Зарегистрирован: Вс сен 16, 2012 9:39 am
Благодарил (а): 0
Поблагодарили: 1 раз

Re: Ошибки/проблемы/неисправности системы

Сообщение Urbas81 » Вт окт 10, 2017 10:42 am

xor писал(а):Посмотрите вкладку Structure в x-ray'е, я время от времени сохраняю эту страницу локально. Там практически всё показывается в человеческом виде (кроме галочек/крыжиков интерфейса).
Несколько раз выручало конкретно после неудачных опытов с разрушением базы когда не помогало восстановление из бэкапа.
Да, туда заглядывал, в принципе и через базу вижу что галочка установлена, но в самом интерфейсе не отображается, ну и пункты дублируются, одни по 2 раза, другие по 3.
Аватара пользователя
nick7zmail
Сообщения: 7530
Зарегистрирован: Пн окт 28, 2013 8:14 am
Откуда: Екатеринбург
Благодарил (а): 121 раз
Поблагодарили: 1991 раз

Re: Ошибки/проблемы/неисправности системы

Сообщение nick7zmail » Вт окт 10, 2017 11:49 am

У вас возможно глючно база восстановилась. Произошло "наложение" старой на новую...кто-то такое в ручную чистит, кто-то новую базу заливает....

Я кому-то уже говорил как почистить задвоившиеся пункты...надо просто найти таблицу с ними, и удалить дубликаты...сейчас точно не помню имя таблицы...вроде project_modules что ли...
Raspberry Pi3+Broadlink+esp8266 (blynk)+AMS
Если вам помогло какое-либо сообщение - не забывайте пользоваться кнопкой "СПАСИБО".
:arrow: Услуги в профиле коннект
>>>>>Мой новый канал на ютутбе, подписывайтесь!<<<<<
Urbas81
Сообщения: 289
Зарегистрирован: Вс сен 16, 2012 9:39 am
Благодарил (а): 0
Поблагодарили: 1 раз

Re: Ошибки/проблемы/неисправности системы

Сообщение Urbas81 » Вт окт 10, 2017 12:57 pm

nick7zmail писал(а):У вас возможно глючно база восстановилась. Произошло "наложение" старой на новую...кто-то такое в ручную чистит, кто-то новую базу заливает....

Я кому-то уже говорил как почистить задвоившиеся пункты...надо просто найти таблицу с ними, и удалить дубликаты...сейчас точно не помню имя таблицы...вроде project_modules что ли...
Спасибо, почистил вручную, задвоение ушло. Заметил по пункту выполнять периодически в скриптах, если устанавливаю воскресенье, галочка не отображается, в базу пишется 0, все другие дни отображается, это только у меня так? (Проверил еще, если воскресенье+любой другой день, то отображается и воскресенье). Еще вопрос, удалял датчики температуры, пришлось почистить phistory и восстановить базу через файл sql, теперь новые значения на графике highchsrts выводятся с датой несоответствующей действительности, хотя в базу пишется правильно, куда копать?
Sat
Сообщения: 25
Зарегистрирован: Пт авг 07, 2015 5:08 pm
Благодарил (а): 2 раза
Поблагодарили: 3 раза

Re: Ошибки/проблемы/неисправности системы

Сообщение Sat » Ср окт 18, 2017 9:56 am

Добрый день.
Внезапно обнаружил, что перестали работать пункты меню управления, тип который указан как "Ссылка".
Скорее всего отвалилось после какого-нибудь обновления.
Если же тип меню поменять на "Ссылка (Новое окно)", ссылка открывается (в новом окне).
Хотелось бы починить, чтоб работал тип "Ссылка", чтоб содержимое ссылки открывалось в рабочей области портала, как раньше.
Не знаете в чем дело?
Аватара пользователя
nick7zmail
Сообщения: 7530
Зарегистрирован: Пн окт 28, 2013 8:14 am
Откуда: Екатеринбург
Благодарил (а): 121 раз
Поблагодарили: 1991 раз

Re: Ошибки/проблемы/неисправности системы

Сообщение nick7zmail » Ср окт 18, 2017 10:15 am

Хм...вроде работало...надо проверить дома.
А вы не пользуетесь альтернативными шаблонами? Папкой templates_alt...может вы удаляли ранее страничку с заголовком ***? В ней как раз, вроде, и открываются такие ссылки.
Raspberry Pi3+Broadlink+esp8266 (blynk)+AMS
Если вам помогло какое-либо сообщение - не забывайте пользоваться кнопкой "СПАСИБО".
:arrow: Услуги в профиле коннект
>>>>>Мой новый канал на ютутбе, подписывайтесь!<<<<<
Sat
Сообщения: 25
Зарегистрирован: Пт авг 07, 2015 5:08 pm
Благодарил (а): 2 раза
Поблагодарили: 3 раза

Re: Ошибки/проблемы/неисправности системы

Сообщение Sat » Ср окт 18, 2017 10:31 am

использую альтернативный шаблон default.htm
переименовал его, портал загрузился с исходным шаблоном, но меню-ссылки так и не заработали
Закрыто